USN-3178-1: icoutils vulnerabilities

Ubuntu Security Notice USN-3178-1

24th January, 2017

icoutils vulnerabilities

A security issue affects these releases of Ubuntu and its
derivatives:

  • Ubuntu 12.04 LTS

Summary

icoutils could be made to crash or run programs as your login if it opened
a specially crafted file.

Software description

  • icoutils
    – Create and extract MS Windows icons and cursors

Details

It was discovered that icoutils incorrectly handled memory when processing
certain files. If a user or automated system were tricked into opening a
specially crafted file, an attacker could cause icoutils to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following
package version:

Ubuntu 12.04 LTS:
icoutils

0.29.1-2ubuntu0.1

To update your system, please follow these instructions:
https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-5208,

CVE-2017-5331,

CVE-2017-5332,

CVE-2017-5333


Source From: ubuntu.com.
Original article title: USN-3178-1: icoutils vulnerabilities.
This full article can be read at: USN-3178-1: icoutils vulnerabilities.

Advertisement


Random Article You May Like

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*