iOS 10.3 Beta Says 32-Bit Legacy Apps Will Not Work With Future Versions of iOS

Since iOS 10.1, when a user opens an old 32-bit app on a newer iPhone, iPad, or iPod touch, Apple has reinstated a warning that the app may slow down the device until the developer updates it to improve its compatibility. The apps are still fully usable, however, despite the possible performance issues.

appshopper_needs_updated
On iOS 10.3 beta, Apple has tweaked the wording of that warning to note that 32-bit apps “will not work with future versions of iOS,” suggesting that iOS 11 could be the first software update to support 64-bit apps only. “Future versions” is unsurprisingly vague, however, so the exact timeline remains unclear.

Apple has supported 64-bit apps since the iPhone 5s launched in September 2013. The company required that all new apps support 64-bit architecture as of February 2015, and all updated apps since June 2015, but a number of older 32-bit apps that have not been updated in years remain available on the App Store.

iOS devices with a 64-bit chip include the iPhone 5s and newer, iPad Air and newer, iPad mini 2 and newer, and sixth-generation iPod touch.

In September, Apple said it would begin removing problematic and abandoned apps from the App Store, including those that no longer function as intended or follow current review guidelines, and others lacking compatibility updates for a long time. By October, it was reported some 50,000 apps had already been removed.

Related Roundup: iOS 10
Tag: App Store

Discuss this article in our forums


Source From: macrumors.com.
Original article title: iOS 10.3 Beta Says 32-Bit Legacy Apps Will Not Work With Future Versions of iOS.
This full article can be read at: iOS 10.3 Beta Says 32-Bit Legacy Apps Will Not Work With Future Versions of iOS.

Advertisement


Random Article You May Like

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*