USN-3186-1: iucode-tool vulnerability

Ubuntu Security Notice USN-3186-1

1st February, 2017

iucode-tool vulnerability

A security issue affects these releases of Ubuntu and its
derivatives:

  • Ubuntu 16.10
  • Ubuntu 16.04 LTS

Summary

iucode-tool could be made to crash or run programs if it opened a specially
crafted file.

Software description

  • iucode-tool
    – Intel processor microcode tool

Details

It was discovered that iucode-tool incorrectly handled certain microcodes
when using the -tr loader. If a user were tricked into processing a
specially crafted microcode, a remote attacker could use this issue to
cause iucode-tool to crash, resulting in a denial of service, or possibly
execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following
package version:

Ubuntu 16.10:
iucode-tool

1.6.1-1ubuntu0.1
Ubuntu 16.04 LTS:
iucode-tool

1.5.1-1ubuntu0.1

To update your system, please follow these instructions:
https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-0357


Source From: ubuntu.com.
Original article title: USN-3186-1: iucode-tool vulnerability.
This full article can be read at: USN-3186-1: iucode-tool vulnerability.

Advertisement


Random Article You May Like

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*