USN-3288-1: libytnef vulnerabilities

Ubuntu Security Notice USN-3288-1

15th May, 2017

libytnef vulnerabilities

A security issue affects these releases of Ubuntu and its
derivatives:

  • Ubuntu 14.04 LTS

Summary

libytnef could be made to crash or run programs as your login if it opened
a specially crafted file.

Software description

  • libytnef
    – improved decoder for application/ms-tnef attachments

Details

It was discovered that libytnef incorrectly handled malformed TNEF streams.
If a user were tricked into opening a specially crafted TNEF attachment, an
attacker could cause a denial of service or possibly execute arbitrary
code.

Update instructions

The problem can be corrected by updating your system to the following
package version:

Ubuntu 14.04 LTS:
libytnef0

1.5-6ubuntu0.1

To update your system, please follow these instructions:
https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart applications using
libytnef, such as Evolution, to make all the necessary changes.

References

CVE-2017-6298,

CVE-2017-6299,

CVE-2017-6300,

CVE-2017-6301,

CVE-2017-6302,

CVE-2017-6303,

CVE-2017-6304,

CVE-2017-6305,

CVE-2017-6306,

CVE-2017-6800,

CVE-2017-6801,

CVE-2017-6802


Source From: ubuntu.com.
Original article title: USN-3288-1: libytnef vulnerabilities.
This full article can be read at: USN-3288-1: libytnef vulnerabilities.

Advertisement


Random Article You May Like

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*