USN-3397-1: strongSwan vulnerability

Ubuntu Security Notice USN-3397-1

21st August, 2017

strongswan vulnerability

A security issue affects these releases of Ubuntu and its
derivatives:

  • Ubuntu 17.04
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

strongSwan could be made to crash or hang if it received specially crafted
network traffic.

Software description

  • strongswan
    – IPsec VPN solution

Details

It was discovered that strongSwan incorrectly handled verifying
specific RSA signatures. A remote attacker could use this issue
to cause strongSwan to crash, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following
package version:

Ubuntu 17.04:
libstrongswan

5.5.1-1ubuntu3.2
strongswan

5.5.1-1ubuntu3.2
Ubuntu 16.04 LTS:
libstrongswan

5.3.5-1ubuntu3.4
strongswan

5.3.5-1ubuntu3.4
Ubuntu 14.04 LTS:
libstrongswan

5.1.2-0ubuntu2.7
strongswan

5.1.2-0ubuntu2.7

To update your system, please follow these instructions:
https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-11185


Source From: ubuntu.com.
Original article title: USN-3397-1: strongSwan vulnerability.
This full article can be read at: USN-3397-1: strongSwan vulnerability.

Advertisement
The easiest way to create a website for your business. Create your site at Weebly.com!


Random Article You May Like

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*